Technical Requirements

In order to make the maximum use of the site, it is recommended site users have:

A browser: Mozilla™ Firefox 1.x or higher or Microsoft® Internet Explorer version 4.01 or higher.

Some of our pages contain Adobe Flash content. If you are not using Mozilla Firefox 1.X or higher or Internet Explorer 4.01 or higher, you may need to download and install the player. The player is free and can be downloaded from the Adobe Flash Player Download Center. The download takes approximately 1 minute and instructions are provided.

For accessing our guides, you will need the Adobe Acrobat Reader. Acrobat Reader is free and can be downloaded from the Adobe site. The download should only take a few minutes.

Flash Player Flash Player

How to Contact Us

If you are having difficulties with the website, please contact Customer Support or call 1-866-220-3184.